Error message 0xC0C02524 when configuring BizTalk group

Tag: biztalk , biztalk-2009 Author: sunxubosz Date: 2010-10-27

Long time reader, first time poster ;)

I have a problem when configuring a BizTalk 2009 group. I get error 0xC0C02524 without any messages while running the configuration. The log file says nothing of import and the eventlogs on the respective machines do not add any useful information. Basically they say the same thing as the configuration log. The environment consists of a separate BizTalk machine and an SQL machine. I've tried reconfiguring the DTC and dropping firewalls and such, to no avail.

Has anyone ever encountered this problem and solved it? I haven't found anything while googleing =(

Cheers
// Daniel

Best Answer

What version of SQL Server are you using? If it's SQL Server 2008R2, it's not supported. This may be an artifact of that.

comments:

It is indeed SQL 2008R2, also running under Windows Server 2008R2 which isn't supported either. (Been talking to Microsoft support.) I've, temporarily, gotten around it by using a SQL 2005 Express instance on the BizTalk machine. I know this is not good, but when you have a customer breathing down your neck... ;) I'm still hopefull that I can get a proper solution, or atleast a workaround =) Thanks though.
After some back and forth it was unanimously decided that BTS2009 and SQL2008R2 simply does not play nice together. As a result a parallell instance of SQL2008 was installed and now everything is humming along nicely. Thanks for your input!