Hide Site Action WSS 3.0 SharePoint

Tag: sharepoint Author: accpa743 Date: 2009-07-20

I want to give a member a privilege to create a sub site or workspace with same permission as that of parent site. I have changed the OOTB "Contribute" permission level i.e. I have given permission to Create a web site. After doing this a Site Action Menu appear and I don't want it to be displayed when member with "Contribute" permission level is logged in. Is is possible to Hide Site Action at all without using designer?

Other Answer1

Why not just create a new permission set, lets call it "Site Creators", that has all the option checked that contribute has + create site. Then create a new SharePoint group, add your users and add the new permissions set to the group's permissions.

comments:

If I do this then it allows me to create a site with unique permission only under permissions section the radio button for "Use permission same as parent Site" disables I have no choice to select it but I want user to create a site with same permissions as parent site.
That's very odd behavior, just checked it and it worked fine for me...
I am using WSS 3.0 with SP2

Other Answer2

Below are what I do usually. Hope it works for you too.
No.1 Open up the master page in SharePoint Designer.
No.2 Wrap the html of the Site Actions within a SPSecurityTrimmedControl.
No.3 Set the Permissions String as appropriate.