Video embed on facebook wall does not play when on https

Tag: facebook , https , embed Author: li19930819 Date: 2011-09-19

We have set up the open graph tags on our pages to embed a video on the facebook wall of the user that shares the page.

When the video is clicked when on http:// it will play perfectly. When the video is clicked when on https:// (e.g. set up in the privacy settings) only the screenshot is displayed, and links to the shared page.

The situation can be produced by sharing the following URL: and watch it on your wall when using http:// and https://

Vimeo and YouTube videos do play when watched on https

Should we change the headers on our servers or is there a partnership between Facebook and Youtube / Vimeo that allows them show video when the users wall is shown on https?

I see that you figured this out. Looking at your <meta> tags it looks like you only had to change the og:video tag contents to https resources - your og:image, og:url, etc. are still over http. Did you have to do anything alongside of this to get it to work? I tried effectively the same thing, but am not getting the embedding to work over https.
I may have figured it out. I'm using JWPlayer with a file query parameter URL that's not https. I didn't think this would be a problem, but switching the file over to https worked.

Other Answer1

To set up a HTTPS source for the video you need to specify the og:video:secure_url tag and point it to the HTTPS source for the video.

See here: It was announced in yesterdays blog post too:

Other Answer2

The secure_url tag does not work, nor do Youtube and Vimeo use it. I've only managed to resolve this by serving content over https


The solution is to only include https urls. This is the most effective approach I have seen so far.

Other Answer3

try <meta property="og:video:secure_url" content="http://..." />


Thanks Paul, we will test this asap.
Update: Chrome will no longer validate SSL certificates when video player redirects to http sources when embedded on https
Open Graph no longer accepts urls with a prefix of http for og:video:secure_url, they must start with https