TSAgg R package error message: namespace ‘memoise’ is not available

Tag: r Author: rainlaker Date: 2013-09-10

I am trying to use the TSAgg package to aggregate my data over days. However, I get a the following error message:

> Data.1day<-daysAgg(Data.ts,mean)
Warning: namespace ‘memoise’ is not available and has been replaced
by .GlobalEnv when processing object ‘sep’
Warning: namespace ‘memoise’ is not available and has been replaced
by .GlobalEnv when processing object ‘sep’
Error in .get_loc_regs(locale) : could not find function "digest"

When I loaded TSAgg, there was the following warning message: Warning messages:

1: package ‘TSAgg’ was built under R version 3.0.2 
2: package ‘lubridate’ was built under R version 3.0.2 

I am using R version 3.0.1 as I don't want to use a test build. Is there anything I can do to make it work?

This is a wild guess, but try install.packages("memoise"). lubridate depends on the package memoise, so it may be that that dependency wasn't correctly installed for you (for whatever reason).
That works, thanks!